Jump to content

Missing Terrain and Autogen P3Dv4.5


Recommended Posts

Hello, 

 

I recently purchased this product yesterday and so far it has completely changed my sim, for the worse. When I applied the tweaks and added a preset everything seemed to of disappeared from my sim. 

I restored original shaders, files, etc as to what it was before and it still has not repaired the issue. 

 

I have then went onto reinstalling the client, content and scenery and still no fix. 

 

Very frustrating.  

 

 

2022-3-31_19-11-7-146.jpg

Link to comment
Share on other sites

  • RDPresets Staff

Hello

This issue has been discussed on the forum many times as this is an issue all users with V4.5 currently have, we are finishing a hotfix that will solve this issue. To fix this in the short term place this file GPUTerrain.fx in your ShaderHLSL folder and replace it, this way your terrain will be fixed 🙂 We expect to release the hotfix today or tomorrow to solve all the issues.

 

Kind regards

GPUTerrain.fx

Link to comment
Share on other sites

  • 2 months later...
On 4/1/2022 at 2:06 PM, RDPresets - Robin said:

Hello

This issue has been discussed on the forum many times as this is an issue all users with V4.5 currently have, we are finishing a hotfix that will solve this issue. To fix this in the short term place this file GPUTerrain.fx in your ShaderHLSL folder and replace it, this way your terrain will be fixed 🙂 We expect to release the hotfix today or tomorrow to solve all the issues.

 

Kind regards

GPUTerrain.fx 61.27 kB · 62 downloads

Hello i have the same problem in Prepar3dv5 please advice how to anjoy the flights, regards Constant

2022-5-31_9-48-55-241.jpg

2022-6-1_14-8-32-391.jpg

Link to comment
Share on other sites

  • RDPresets Staff

Hi,

This problem is not the same problem as the one above, as in the issue cause by RDShade, textures are missing, in your case, the textures are all blended together, this is an issue caused by ORBX, you should fix your library in orbx central to fix this issue.

 

Kind regards

Robin

Link to comment
Share on other sites

  • 4 weeks later...

Hi, guys. I'm having the same issue that callumell28  is having. I was using the GPUTerrain.fx file and replacing it just corrected the terrain texture only, but the autogen was still missing. 

We got the new update this weekend and I was really excited, hoping this would fix this issue, but, unfortunately, even after the update it still happens. 
I'm not being able to use RDShade as no matter what, if try the shaders, I lose the ground or autogen. 

Is there any other fix that you guys could try? 

I'm running P3D v4.5 HF3 on Windows 7. 

Link to comment
Share on other sites

  • RDPresets Staff

Hi,

That’s strange as we have tried to fix this issue in the latest update, have you tried the GPUTerrain.fx fix? If this doesn’t work either do you know how to send us your content log error file? This way we can see what the problem is and fix it for good in the next update.

 

we apologies for the inconvenience and we will try to fix is as soon as possible when we have the required information 🙂

 

kind regards

Robin

Link to comment
Share on other sites

  • 2 weeks later...
On 7/6/2022 at 5:42 PM, RDPresets - Robin said:

Hi,

That’s strange as we have tried to fix this issue in the latest update, have you tried the GPUTerrain.fx fix? If this doesn’t work either do you know how to send us your content log error file? This way we can see what the problem is and fix it for good in the next update.

 

we apologies for the inconvenience and we will try to fix is as soon as possible when we have the required information 🙂

 

kind regards

Robin

Hi, Robin! Thank you for your quick response. 

Sorry if I took so long to see it. I've been working a lot lately. 
Can you give me instructions on how to collect this log? I'll be more than happy to help you with this.  

I also tried uninstalling the older version of the app and reinstalling with the updated installer, to no avail. 

Just reminding you that I run my sim on a Windows 7 OS. I'm not sure if this would affect something, but, I don't know. 

Again, thank you! 

Edited by SierraAero
Link to comment
Share on other sites

The content log is generated by P3D and is turned on by the first screenshot and then the error log is located at wherever you have your documents/prepar3d v5 files. The path shown is my non-standard location so ignore the drive letter (yours might be c:).

Hope this helps.

content error log.png

location.png

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

Hello, RDPresets, thank you first for the beautiful you created. I had purchased your program yesterday from SimMarket and I am facing the same issue as the guys mentioned above. 

Hong Kong after applying changes to water texture

The water texture is entirely missing once I change the environment water surface shaders.

 

Sending you log for content errors recorded from sim, I am on V4.5 HF3. 

 

ContentErrors.txt

Link to comment
Share on other sites

  • RDPresets Staff

HI Pavlin,

Thank you for your purchase. I just took a look at your content error file but unfortunatly there are not RDShade errors in there due to the many errors you have in your simulator. P3D can only report up to 999 errors. and I filled all of the 999 before getting to the potential RDShade / shader issue.

If you could try to remove these other errors so we can see what the shader problem may be.

Thank you!
Robin

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...